Log in
Log in

or
Create an account

or

Thread No hardware found

  • 4 replies
  • 5 participants
  • 6,667 views
  • 5 followers
1 No hardware found
Hello,

I been struggling with this problem for hours and still no solution. I have a Hp pavilion windows 7 64 bit, and just bought the Focurite Saffire pro 24. Everything I try has not worked, when I go to open Saffire mixcontrol it says no hardware connected. I've went into bios and disabled my soundcard, uninstalled saffire software, reinstalled a few times. I've went with the recommended driver (Legacy)with the new software mixer from Focusrite. I can't think of anything else to do. I know others with windows 7 have this interface and they've got it to work.

Any help would be appreciated. Also my computer firewire matches what came with the interface, as I thought they didn't. Normally windows 7 detects new devices but it didn't this time. Thanks to all who can help me out.
2
The same f***ng problem! where's the f***n support?!!!
3
Firstly you should check your hardware configurations, then update your system BIOS settings, if you window does not supported any hardware then reinstall it and you can also scan your system with Malware Removal for virus detection.
4
I have the same problem. I'll try to follow the advices but i don't see anything new in checking for malware....)
5
Dear all,

Thanks for your posts.

Please don't hesitate to visit our anwerbase or contact our support should you have any queries.

With best regards,

Marcel Saba // Focusrite Novation Support