Log in
Log in

or
Create an account

or

Thread Scarlet 2i2 crashing

  • 2 replies
  • 3 participants
  • 3,256 views
  • 3 followers
1 Scarlet 2i2 crashing
Hello all.

For 3-4 months i have the focusrite scarlet 2i2.It was working perfectly till yersterday.Heres the story :

I had windows 7 ultimate x64 installed on my pc.But i got a virus and i had to format the harddrive...So i installed Windows XP SP2 x64.
I installed all the drivers for the pc and i downloaded the drivers for scarlet.But the problem is that everytime i play a song, on windows media player or youtube, after some seconds the audio/video(video=youtube) stops and it plays some very weird noises...Sometimes i can hear audio but is like lower than 8-bit sound...Something like distorted.

I tried to record something with my mic, it was working for 2-3 minutes but then i was hearing a clock sound.
An distorted clock sound.

So, i managed to test the sound from my motherboard sound card.It was ok.No distortion.Nothing.

It looks like the problem is with my card.
Its the first time im facing a problem like this...

I hope you can help me...Thanks for your time :)
2
can you provide more information? exact computer specs/operating system/RAM/what drivers you have installed/etc? And have you tested to make sure the USB isn't causing any issues?
3
Good morning,

Thanks for your post and sorry to hear you are experiencing some issues.

Firstly, please note that the 2i2 us untested and unsupported on Windows XP, as such, there may be issues that we're not aware of.
To ensure that Windows as assigned the correct driver, please navigate to Control Panel -> Device Manager -> right-click on interface in Sound, Video & Game Controllers -> Update driver software -> Browse My Computer -> Let me pick from a list -> Ensure 2.5.128.1 is selected and click Next

Please look through the following optimisation steps and power management settings:

https://uk.focusrite.com/answerbase/optimising-your-pc-for-audio-on-windows-xp

Have you tried all other USB ports? Some are internally hubbed and can cause issues. Please try each one and monitor the performance of the interface.

Please ensure you have disabled power saving mode for USB devices:

In the device manager (Start > Control Panel > System and Security > System > Device Manager), in the Universal Serial Bus controllers section, right click each USB Root Hub, choose Properties > Power Management and untick the Allow the computer to turn off this device to save power option.

USB Power

If using a Laptop, it could also be worth checking the general power management of your computer:
Go to Start > Control Panel > System and Security > Power Options.
Set the Power Scheme to High Performance (if this setting is not available, click on Show additional plans first). Then click on Change plan settings. On the next page set both Turn off the display and Put the computer to sleep to Never.

Power Options

Then click Change advanced power settings. In the window that opens make sure you have the following settings:
Hard disc > Turn off hard disk after > Setting (Minutes) = Never
Sleep > Sleep after > Setting (Minutes) = Never
USB settings > USB selective suspend setting > Setting = Disabled
Display > Turn off display after > Setting (Minutes) = Never
Processor power management > Minimum processor state > Setting = 100%
Processor power management > Maximum processor state > Setting = 100%

Please note, not all options may be available.

It could also be worth checking for any available USB/Chipset driver updates for your motherboard.

Are you using the USB cable that came packaged with the 2i2?
Are you connecting the 2i2 directly to your PC and not via a hub?

Please let me know how you get on

Best regards

--
Simon // Focusrite Technical Support