Log in
Log in

or
Create an account

or

Thread Focusrite Scarlett 2i4 PROBLEMS

  • 1 comment
  • 2 participants
  • 3,561 views
  • 2 followers
1 Focusrite Scarlett 2i4 PROBLEMS
Hi guys.

I'm having problems with my focusrite. I've had it for about 2 years now.
I had no problems when I used it with my mac.

I recently moved to Windows and I am having problems getting it to work.
I installed the driver, I did everything I should do, I think...

When I connect it to the PC the USB Connection light on the 2i4 flashes as well as the 2 volume buttons???

I don't know if my graphics card or something could be causing the problem.
Can anyone help me.

Thanks.

Here is my PC Specs:
Windows 8.1 pro
motherboard - AsRock Z97 Pro4
graphics- MSI R7 250 (Radeon R7 Series)
Intel Core i5 processor.
2
Hi HagenB,

Sorry that you seem to be having some issues with the 2i2 on your Windows PC.
Presumably the 2i2 is still working fine with your Mac after you've encountered these issues?

To ensure that Windows as assigned the correct driver, please navigate to Control Panel -> Device Manager -> right-click on interface in Sound, Video & Game Controllers -> Properties -> Driver -> which driver version is listed?

Please run through the following Windows 8 optimisation steps:

https://global.focusrite.com/answerbase/optimising-your-pc-for-audio-on-windows-8

Have you tried another USB port? Some are internally hubbed and can cause issues. Please try each one and monitor the performance of the interface.

Please ensure you have disabled power saving mode for USB devices:

In the device manager (Start > Control Panel > System and Security > System > Device Manager), in the Universal Serial Bus controllers section, right click each USB Root Hub, choose Properties > Power Management and untick the Allow the computer to turn off this device to save power option.

USB Power

If using a Laptop, it could also be worth checking the general power management of your computer:
Go to Start > Control Panel > System and Security > Power Options.
Set the Power Scheme to High Performance (if this setting is not available, click on Show additional plans first). Then click on Change plan settings. On the next page set both Turn off the display and Put the computer to sleep to Never.

Power Options

Then click Change advanced power settings. In the window that opens make sure you have the following settings:
Hard disc > Turn off hard disk after > Setting (Minutes) = Never
Sleep > Sleep after > Setting (Minutes) = Never
USB settings > USB selective suspend setting > Setting = Disabled
Display > Turn off display after > Setting (Minutes) = Never
Processor power management > Minimum processor state > Setting = 100%
Processor power management > Maximum processor state > Setting = 100%

Please note, not all options may be available.

It could also be worth checking for any available USB/Chipset driver updates for your motherboard, including the latest BIOS updates.

Let me know how you get on.
Simon // Focusrite Technical Support

[ Post last edited on 09/01/2015 at 05:01:07 ]