Log in
Log in

or
Create an account

or

Thread pro 24

  • 1 comment
  • 1 participant
  • 977 views
  • 1 follower
Topic pro 24
Hello!

So, i updated to 3.7, restarted pc and boom, no hardware connected. :(( Also i noticed when i turn on pc and when it loads up to windows, FW and LKD lights were blinking for a moment? No audio. And after the second restart FW went on for like 3 seconds and then turned off... In Device manager its showing me Saffire and in windows playback devices its also showing me Saffire audio and is enabled. But no audio. Also no hardware detected.

7s7i76L.jpg

https://i.imgur.com/7s7i76L.jpg

So, i tried downgrade. Nope, 3.4 used to be before, not working now. Changed firewire slots, it was "device installing" the device but same results, showing Saffire audio but mixcontrol says no hardware connected and no audio, even after pc restart.

Any ideas/solutions?

Windows 10 user.

Worked well with windows 10 before.

EDIT: I uninstalled driver, also uninstalled from device manager, after restart it appears there again. I double checked...
Ty for stepping by.

[ Post last edited on 03/08/2016 at 15:36:52 ]

2
Ight! I got it working. Back on 3.4.

What i did was, disconnect all hdmi displays/usb/firewire/ devices and left only saffire alone connected, uninstalling mixcontrol, uninstalling saffire audio from device manager, deleting all saffire files from windows/system folder. (It's own risk)(used unlocker to delete). Shut down saffire, restarted pc.

Installed mixcontrol, restarted pc.

Turned on saffire, FW and LKD lights were blinking, till i got on windows and it auto-installed audio. Woalaa FW green and audio is working.

If you have something similar, doing these steps are risky and may harm hardware.

[ Post last edited on 03/09/2016 at 08:00:50 ]