Log in
Log in

Create an account


Thread Swapped out AI; now have Scarlett 2i4 - nothing works now (newbie)

  • 1 comment
  • 2 participants
Topic Swapped out AI; now have Scarlett 2i4 - nothing works now (newbie)
Sorry - new to this forum, and just posted this in another, general category - just noticed this Scarlett-specific one.


Hi. I'm relatively new to home recording, so the solution here may be obvious to many of you.

I've been borrowing a Roland Quad-Capture audio interface for awhile, and tonight brought home a Focusrite Scarlett 2i4, 2nd gen, new in box.

My setup is condenser mic connected to AI; headphones connected to AI; AI to laptop; small laptop speakers connected to laptop. DAW is FL Studio. OS is Windows 10.

Installed driver and firmware update.

Opened FL Studio and selected "Focusrite" for input/output.

The LED light on the Scarlett is one; mic and headphones are plugged in, but no other lights other than the LED - volumes are turned up.

I've turned on phantom power.

When i talk in the mic, i get nothing. No gain lights on the AI (knob turned up); no movement on the FL Studio screen.

I changed the input/out selection in my DAW from Focusrite to ASIO4all v2. NOW FL picks up sounds from the mic, but still no movement on the AI, lights wise.

Nothing from the headphones either; cranked up the volume and no hissing sound or anything: dead.

Is this a setting somewhere? Driver issue? Hardware issue? Combination? I’m very frustrated and maybe not seeing the obvious... The setup is the same as with the Roland, other than changing the setting in the DAW to Focusrite.


[ Post last edited on 06/22/2017 at 06:39:52 ]

Hi ccmc,

Sorry that I've only just seen this.

This could be due to a whole host of factors so I'll try and answer as most comprehensively as possible.

First step would be to try all the available USB ports on your computer and a different USB cable if you have one as I've seen faulty cables cause issues like this in the past.

Please ensure you have disabled power saving mode for USB devices:

In the device manager (Start > Control Panel > System and Security > System > Device Manager), in the Universal Serial Bus controllers section, right click each USB Root Hub, choose Properties > Power Management and untick the Allow the computer to turn off this device to save power option.

USB Power

If using a Laptop, it could also be worth checking the general power management of your computer:
Go to Start > Control Panel > System and Security > Power Options.
Set the Power Scheme to High Performance (if this setting is not available, click on Show additional plans first). Then click on Change plan settings. On the next page set both Turn off the display and Put the computer to sleep to Never.

Power Options

Then click Change advanced power settings. In the window that opens make sure you have the following settings:
Hard disc > Turn off hard disk after > Setting (Minutes) = Never
Sleep > Sleep after > Setting (Minutes) = Never
USB settings > USB selective suspend setting > Setting = Disabled
Display > Turn off display after > Setting (Minutes) = Never
Processor power management > Minimum processor state > Setting = 100%
Processor power management > Maximum processor state > Setting = 100%

Please note, not all options may be available.

It could also be worth checking for any available USB/Chipset driver updates for your motherboard.

Once you've done this I would recommend optimising your computer for audio as per the following.


Lastly please ensure that you have installed the latest driver available here: https://uk.focusrite.com/downloads?product=Scarlett+2i4

If you're still having issues after this then please feel free to open a ticket with us directly by navigating to the following link and we'll be happy to investigate further and get to the bottom of what is causing the issue.


Best regards,

Alex Bull // Focusrite Tech Support