Log in
Log in

or
Create an account

or
Enlarge
Add this product to
  • My former gear
  • My current gear
  • My wishlist
Alesis MultiMix 16 USB 2.0
Images
1/96
Alesis MultiMix 16 USB 2.0

FireWire/USB/mLan Mixer from Alesis belonging to the MultiMix series

Thread Alesis multimix 16 USB 2.0 Driver install error

  • 1 comment
  • 2 participants
  • 3,430 views
  • 2 followers
1 Alesis multimix 16 USB 2.0 Driver install error
:fache:

Basically I have just picked up an Alesis Multimix 16 usb 2.0 off ebay quite cheap and an error message appears when I install the drivers.
It comes up with
"Unfortunately the installation failed.
(Error: timeout - 0x0005)"

My system is Vista so, as everyone who uses Vista and knows how picky it can be, I tried installing it on my laptop aswell, which is on Xp. Same problem.
So I know its not the computer or the OS.

I changed the USB cable just in case.

Ive followed the instruction of install i.e. "dont plug it in until it asks" and tried ignoring that also in a desperate attempt to find a way for it to work.

Basically I think its just not being found as hardware.


Anyone know a solution? Any help would be fantastic!
2
Have you got it working yet? If not, I would send it back to your buyer and get a refund.