Log in
Log in

or
Create an account

or

Thread Signal Dropout with focu rite 18i20 first generation

  • 1 comment
  • 2 participants
  • 983 views
  • 2 followers
1 Signal Dropout with focu rite 18i20 first generation
Hi everyone, I recently bought a first generation focusrite scarlett 18i20 interface. I use logic pro x and the problem is scarlett 18i20 simply cannot be used with DAW. I have installed the driver and it's mixer control software too. The signal drop after about 2 seconds and then would stop playing. I set up the Midi and sound to 14 channel-24 bit integers in the input section and 16 channel-24 bit channel in the output section as suggested by focusrite but does not fix the problem. I tried it in adobe audition to make sure that it is not Logic problem. The same problem persist with adobe audition too. The question is whether I received a faulty product or is it a driver problem? Help would be appreciated.
2
Hi Sanaring,

I'm Alex from Focusrite Tech support and I'll like to help you with your problem with your Scarlett 18i20.

This is most likely a software issue and is a bug with Mac OS's core audio driver whereby I imagine you switched it to 96k and now you are having trouble playing audio.

Please don't open any DAW software and go to Audio MIDI Set Up and change the sample rate to 44.1kHz. Then restart the Mac. Then play some audio from iTunes making sure that it's at 44.1kHz (Don't open the DAW at this stage). Restart the computer again.

Now please trash your audio preferences as per the instructions in this article and restart the computer for a final time.

https://support.focusrite.com/hc/en-gb/articles/206849239-How-do-I-Delete-my-Audio-Preferences-on-Mac-OS-X-

Hopefully this should solve the issue. If it doesn't then you will need to open up a support ticket with us directly at the following address.

https://support.focusrite.com/hc/en-gb/requests/new

Best regards,

Alex Bull // Focusrite Tech Support