Log in
Log in

or
Create an account

or

Thread Scarlett Solo issues

  • 6 replies
  • 2 participants
  • 5,355 views
  • 2 followers
1 Scarlett Solo issues
Hi,

I just got Scarlett Solo to use for playing and recording electric guitar using Reaper and some VST effects. I've tried it on two PCs (laptop and desktop), both having win7 and both have some issues (although different). I should note that I have another NI Komplete 6 interface that works flawlessly with both computers. I installed latest drivers from the website.

Desktop issues: I get the sound of the guitar but after few seconds it just stops permanently. When I open device configuration and just click ok without changing anything, it starts working again for a couple of seconds and stops. ASIO4ALL seems to be working. I ran DPC Latency Checker and it's very low, no spikes or anything. I tried all USB ports on the computer, v2.0, v3.0, all with the same results.

Laptop issues: Sound doesn't stop, but whatever change I make in scarlett control panel, it reverts it back to stock values (512 samples and 50ms latency). It's unusable like that for guitar as latency is really obvious.

Anyone experienced similar issues? Any clues what could cause them?

It's a nice looking and decent made device, it's a shame they include such bad drivers with them.

Cheers,
Bane

[ Post last edited on 03/19/2015 at 06:17:44 ]

2
HI Bane,

Sorry to hear that you're experiencing some problems.
I suspect that your Laptop is an AMD CPU chipset, however please could you confirm whether your desktop is an Intel or AMD chipset?

On both computers, please ensure that you have optimised your computer for audio by following these steps:

https://global.focusrite.com/answerbase/optimising-your-pc-for-audio-on-windows-7

Please ensure you have disabled power saving mode for USB devices:

In the device manager (Start > Control Panel > System and Security > System > Device Manager), in the Universal Serial Bus controllers section, right click each USB Root Hub, choose Properties > Power Management and untick the Allow the computer to turn off this device to save power option.

USB Power

If using a Laptop, it could also be worth checking the general power management of your computer:
Go to Start > Control Panel > System and Security > Power Options.
Set the Power Scheme to High Performance (if this setting is not available, click on Show additional plans first). Then click on Change plan settings. On the next page set both Turn off the display and Put the computer to sleep to Never.

Power Options

Then click Change advanced power settings. In the window that opens make sure you have the following settings:
Hard disc > Turn off hard disk after > Setting (Minutes) = Never
Sleep > Sleep after > Setting (Minutes) = Never
USB settings > USB selective suspend setting > Setting = Disabled
Display > Turn off display after > Setting (Minutes) = Never
Processor power management > Minimum processor state > Setting = 100%
Processor power management > Maximum processor state > Setting = 100%

Please note, not all options may be available.

It could also be worth checking for any available USB/Chipset driver updates for your motherboard.

On your Laptop, please can you try downloading and installing the following driver to replace the driver already installed:

https://owncloud.focusrite.com/owncloud/public.php?service=files&t=9a6c22504e230c260f4734d99b041b61

To ensure that Windows as assigned the correct driver, please navigate to Control Panel -> Device Manager -> right-click on interface in Sound, Video & Game Controllers -> Update driver software -> Browse My Computer -> Let me pick from a list -> Ensure 2.5.128.2 is selected and click Next

If your Desktop is also an AMD chipset, please repeat this step on that computer too.
Please let me know how you get on.

Simon // Focusrite Technical Support
3
Hi,

laptop is AMD based. Desktop is intel i5 quad core. At this point it's more important to me to get it running on desktop because I use Komplete 6 with my laptop.

Cheers,
Bane
4
Simon,

I ran DCP Latency tool on both machines and they are consistently in the green, which is expected. Both machines work fine with the other interface I own.

I tried downgrading drivers on the laptop as you suggested. Good thing is that now it does accept configuration changes. The really bad thing is that any buffer size less than maximum makes awful clipping-like noise. I recorded a sample and uploaded to http://www.diy-fever.com/temp/scarlett_noise.wav

Of course, with buffer size at max, latency is too high to be usable, so it's not much of an improvement.

Also, less important, but any change in sample rate crashes the drivers and DAW and won't allow me to change the value anymore until I reinstall the drivers.

Thanks,
Bane
5
Hi Bane,
Listening to your clip, I think I can hear the clipping that you mean, but to my ears it sounds inherent in the drive sound you're using.
Please can you let me know how you recorded the clip? Do you get the same issue if you record your guitar clean? I take it no clipping is apparent on the Scarlett when recording?

With regards to latency, have you tried using the Direct Monitor switch on your Scarlett? With this set to on (assuming you're using external effects) you will experience no latency. You will want to turn off the input monitoring within your DAW in order to avoid an monitoring echo.

With regards to the sample-rate change issue, this is unusual, please can you let me know the process that you go through to change the sample-rate?
Is this closing one session, then starting a new session with a new sample-rate?

Let me know how you get on.

Simon // Focusrite Technical Support
6
Hi Simon,

I'm using VST effects, no external hardware effects, so direct monitoring is not an option, as it will output clean guitar signal. The raspy clipping noise is definitely not part of the drive effect because it disappears as soon as I set buffer size to max value (10ms). It appears even at 9ms and gets progressively worse as you lower the latency. Nothing else is changed that could affect the noise (levels, effect settings).

Luckily, I was able to make some progress with the desktop machine. I upgraded BIOS and moved all devices around different USB ports and now it doesn't freeze after a couple of seconds. That's good progress, although still not all the way there. A couple of times a minute, in random intervals I get a brief popping noise. I set the device in recording mode and 128 samples of buffer.

Cheers,
Bane

[ Post last edited on 03/20/2015 at 04:54:38 ]

7
Hi Bancika,

Just as a test, does the popping and noise completely disappear if you increase the samples to 1024 (full)?
Obviously this creates a large latency, but if it does resolve the issue, then working backwards through the sample sizes will give you a good indication of where you can leave it sitting and still achieve clear audio.
Obviously the difficulty is that you're wishing to use a plugin to give you a sound that you wish to hear real-time (as opposed to applying a plugin after recording), as such you need to low latency, however some guitar VST instruments (or amp plugins etc) can be quite resource heavy, causing pops and glitches at low buffer sizes. Essentially it's a balancing act.

Let me know how you get on.

Simon // Focusrite Technical Support