Focusrite Scarlett2 18i20
+
Focusrite Scarlett2 18i20

Scarlett2 18i20, USB audio interface from Focusrite in the Scarlett 2nd Generation series.

Prices starting at $550 average price: $550
  • Like
  • Tweet
  • Submit
  • Email

18i20 v2 Won't record unless I run Audition as Administrator (Adobe Audition)

 
AuthorsPosts

mlbuie

user offline
mlbuie
1 post
New AFfiliate

1 Posted on 04/18/2019 at 08:05:26Direct link to this post
I haven't done multi-track recording for a while. Been working mostly in Premiere as DP/Editor and using Audition for fix-up.

I am recording my band tonight and yesterday purchased Focusrite Scarlett 18i20 USB Audio Interface. I installed the drivers. I configured ASIO and made sure I assigned and armed the tracks in Adobe.

(I using Asus VivoBook PRO 15.6" 4K UHD Touchscreen Business/Gaming Laptop, Intel Quad-Core i7-7700HQ 16GB DDR4 256GB SSD+2TB HDD NVIDIA GeForce GTX 1050 USB Type-C Win 10)

I received intermittent results.

1. The meters would not show input even though I could hear myself in the mic from the Interface.
2. Upon re-boot and Windows diagnostic, I would get a wave form start recording, but then it would stop displaying during that recording session.
3. Restarting the project (even after ensuring the tracks were armed and assigned). Again, I would not see a waveform record.
4. Sometimes one track would record, but when I armed another tack the same way, I got no input.

THEN, I ran as Administrator. It worked as expected. I recorded track, changed tracks, recorded again. I recorded 8 tracks simultaneously and played back, no problems encountered. I'm a little afraid of a hiccup tonight, but, it seems to be ok, now.

Anyone else have this experience with Run as Administrator mode? Is this normal? Can I fix this?

With my setup, can anyone recommend settings I should try for latency , Sampling rate, buffer size?

Thanks!
Go back to top