Focusrite Scarlett 2nd Generation
SeriesFocusrite Scarlett 2nd Generation

Series belonging to the Scarlett series from Focusrite

News
Articles
Tutorials
Classified Ads
  • Like
  • Tweet
  • Submit
  • Email

Focusrite to Vmware MacOS Sierra

 
AuthorsPosts

j2tC

user offline
j2tC
2 posts
New AFfiliate

1 Posted on 08/17/2018 at 18:48:00Direct link to this post
Hi Everyone,

I have tried looking through the forum for my issue, but it seems no one has either had my issue or has attempted it.
I am running Windows 10 on an intel i5 7th gen laptop that has 24GB RAM.
I have VMWare installed in my laptop and have set up Mac OS Sierra as a Virtual Machine with 8GB RAM dedicated while running.
I have no problem running my hardware on my Windows 10 with Ableton.
On the Mac OS Sierra Virtual Machine, I have Garageband installed.
Garageband does see the scarlett USB input (1,2,and 1+2) and outputs; however, when sound is going into the interface Garageband is not able to process any sound going in. I double checked the Garageband option to be able to listen to the playback as it's being fed through the interface and again the inputs and outputs are set to scarlett. Also, when adding Guitar or Mic, the correct input is selected (Mic being input 1, Guitar being input 2).
The Focusrite interface is working as my studio monitors are providing playback.
Even while doing this, I have opened Ableton on Windows 10 to ensure sound is going from the interface, through the USB to the laptop.

I have also done a sound check on YouTube to ensure that when audio is being played from MacOS VM, it is going through the interface and out of my studio monitors.

If anyone has had this issue and knows if there is some kind of setting I am missing, I would appreciate the help!

Thank you

angelie

user offline
angelie
317 posts
AFfluent Poster

2 Posted on 09/20/2018 at 02:53:44Direct link to this post
Hi,

OK just to be sure... :)

# You have pc / windows 10
# On that machine runs some kind of sandbox in which you run an apple os
# The apple os run garage band.
# You have plugged in your interface in the pc
And works great on your pc software.
# your sandbox Apple os sees the audio infer face but is not able to use it.

My thoughts :

# Windows is linked to the interface and keeps it occupied so that the sandbox os can't use it. { probably you need special drivers for windows like jack or special ASIO drivers. }

I bet you can't use multiple audio software at the same time on your pc
You can use something as Jack.
Audio interface links to Jack for pc.
Both audio programs are looking to Jack.

# The sandbox is not completely compatible.......sees the interface but can't use it.


- Angelie

It's not about what you got to use but how you use what you got.

[ Post last edited on 09/20/2018 at 02:53:59 ]

j2tC

user offline
j2tC
2 posts
New AFfiliate

3 Posted on 09/25/2018 at 19:20:06Direct link to this post
Thank you, Angelie.

I have a feeling it's just not compatible when running MAC with VMWare.
I was hoping to find someone on this forum who may have had this issue using their interface and maybe finding a solution. Thanks for the reply. Even if there isn't a solution, it's nice to know someone read through my problem and gave in input.

JohnSkinner

user offline
JohnSkinner
14 posts
New AFfiliate

4 Posted on 11/07/2018 at 18:22:37Direct link to this post
I have used a lot of virtualization software before, but not as familiar exactly with current VMWare on Windows 10 (Last time I used VMWare desktop on Windows was years ago). I would love to help you troubleshoot this, but I haven't had success in the past creating a VM (Virtual Machine) of MacOS. If you could help me with the Mac VM part, I could help you with routing of the audio to your Mac VM. What product name and version of VMWare are you running?

JohnSkinner

user offline
JohnSkinner
14 posts
New AFfiliate

5 Posted on 11/07/2018 at 20:57:07Direct link to this post
j2tc,
Have you tried changing the VMWare settings for your MacOS VM to use USB 2.0, instead of USB 3.0? I see where that has fixed problems for people.
Go back to top