• Like
  • Tweet
  • Submit
  • Email

Scarlett Solo problems - Latency and popping noise

 
AuthorsPosts

Adrian Deans

user offline
Adrian Deans
4 posts
New AFfiliate

1 Posted on 01/15/2015 at 15:27:28Direct link to this post
Hi guys, I received my Scarlett Solo from Amazon yesterday, and after what seemed like a good install, I am having issues with popping noise and bad latency.

System:

Windows 7 Ultimate,
AMD Phenon II 955 3,2Ghz,
8 gigs ram,
Asus M5A78L-M Motherboard
AMD HD5750
Using Amplitube 3.8b and Cubase 5.1
Scarlett Solo connected to USB 2 port
Scarlett rca outs connected to rca inputs on hi-fi

Popping noise:
Static like popping noise when playing Media player/youtube etc, as well as inside Cubase or Amplitube. The noise only happens when there is audio coming from the PC, there is no noise during a quiet section of a MP3 or video, but as soon as there is moderate sound, the popping accompanies it. In fact it seems that the popping level matches the output level of what ever audio I running. Moving the scarlett around has no effect on the amount of noise, neither does changing buffer size settings in Amplitube/Cubase. I have tried turning off my router, the only other devices connected to my pc are KB+Mouse.

Latency:
Using Amplitube standalone, with the Forusrite drivers (latest from website) the lowest latency I can get is 22ms, even with a buffer size of 32. This is totally unusable with Amplitube. When using the asio4all driver, and changing the buffer size in asio4all control panel (accessed via Amplitube hardware settings panel) whatever value I set, does not get updated in Amplitube's own Hardware panel, and the latency doesnt seem to get changed. It's stuck at what sounds to me around 20ms.
Using Cubase is the same experience with both drivers, except that when using asio4all driver, selecting a buffer size less than 512 results in no sound coming in or out of Cubase whatsoever, previously recorded audio files dont even show output on the track meters during playback.

I have tried installing interface after doing a clean install of Windows 7, I have turned off my Wifi/router, I have tried different USB ports, changed poll rate of usb,disabled/uninstalled on-board sound.
Using my onboard sound, I can get 7ms latency in Amplitube using a buffer size of 256, CPU usage around 5%, so I'm assuming my system is up to it?

I have also noticed in one of the settings menus (in Amplitube and in Windows audio settings) there is a Focusrite panel with 3 tick boxes with the options Recording - Balanced - Mixing. When I select 'Recording', the latency displayed below jumps from around 20ms to about 3ms depending on what buffer size I have set. However when I exit this panel and go back to it, it will always default back to having no check box selected and latency back to around 20ms.

Can anybody here offer any suggestions as to what could be the problem. I have never given up on a piece of hardware or software in 15 years of PC usage, I'd hate to give up on this, even with the problems, I could tell how good the thing sounds, the difference in Amplitube was unbelievable. I really want to get it working. Any help would be greatly appreciated.

thanks

Adey

Simon Focusrite

user offline
Simon Focusrite
207 posts
AFfinity Poster

2 Posted on 01/16/2015 at 01:12:43Direct link to this post
Hi Adey,

Thanks for your email and sorry to hear you are experiencing some issues.

What would be really helpful is if you could email us here explaining the issue:

https://global.focusrite.com/answerbase/contact

Are you able to test the Solo unit on another computer in order to see if the same issues occur. If so, please could you include the spec of that second computer within your email.

You may wish to look at the following optimisation steps for Windows 7 system/audio performance:

https://global.focusrite.com/answerbase/optimising-your-pc-for-audio-on-windows-7

Have you tried another USB port? Some are internally hubbed and can cause issues. Please try each one and monitor the performance of the interface.

Please ensure you have disabled power saving mode for USB devices:

In the device manager (Start > Control Panel > System and Security > System > Device Manager), in the Universal Serial Bus controllers section, right click each USB Root Hub, choose Properties > Power Management and untick the Allow the computer to turn off this device to save power option.

USB Power

If using a Laptop, it could also be worth checking the general power management of your computer:
Go to Start > Control Panel > System and Security > Power Options.
Set the Power Scheme to High Performance (if this setting is not available, click on Show additional plans first). Then click on Change plan settings. On the next page set both Turn off the display and Put the computer to sleep to Never.

Power Options

Then click Change advanced power settings. In the window that opens make sure you have the following settings:
Hard disc > Turn off hard disk after > Setting (Minutes) = Never
Sleep > Sleep after > Setting (Minutes) = Never
USB settings > USB selective suspend setting > Setting = Disabled
Display > Turn off display after > Setting (Minutes) = Never
Processor power management > Minimum processor state > Setting = 100%
Processor power management > Maximum processor state > Setting = 100%

Please note, not all options may be available.

It could also be worth checking for any available USB/Chipset driver updates for your motherboard.

Best regards

--
Simon Poulton // Focusrite Technical Support

Adrian Deans

user offline
Adrian Deans
4 posts
New AFfiliate

3 Posted on 01/16/2015 at 05:52:32Direct link to this post
Hi Simon, thanks for your reply.

I have already emailed Focusrite through their UK page, and am waiting for a reply.
I have followed all the steps you listed including all the power options, trying a different USB port, updated drivers for my Mobo/chipset, and it hasn't made a difference at all.

My dad has a Win 7 system, he wont have the right audio connections though so I'll have to bring his tower to my house, major PITA. But that's part of the fun of owning a computer right?https://static.audiofanzine.com/images/audiofanzine/interface/smileys/icon_exorbite.gif

I'll report back in a hour or so.

Thanks Simon.

Adrian Deans

user offline
Adrian Deans
4 posts
New AFfiliate

4 Posted on 01/17/2015 at 07:09:49Direct link to this post
Hi Simon, sorry for taking so long to get back, my Internet went down yesterday (just to rub salt in) and I had an engineer out to replace the router. Unfortunately the guy knew nothing about audio interfaces!

I have received an email back from a Focusrite tech support person, this is the info I have sent him per his request.

DPC Latency Monitor
https://medias.audiofanzine.com/images/thumbs3/1903144.jpg

Latency Monitor Tool
_________________________________________________________________________________________________________
CONCLUSION
_________________________________________________________________________________________________________
Your system appears to be suitable for handling real-time audio and other tasks without dropouts.
LatencyMon has been analyzing your system for 0:01:11 (h:mm:ss) on all processors.


_________________________________________________________________________________________________________
SYSTEM INFORMATION
_________________________________________________________________________________________________________
Computer name: PC
OS version: Windows 7 Service Pack 1, 6.1, build: 7601 (x64)
Hardware: ASUSTeK Computer INC., M5A78L-M/USB3
CPU: AuthenticAMD AMD Phenom(tm) II X4 955 Processor
Logical processors: 4
Processor groups: 1
RAM: 8190 MB total


_________________________________________________________________________________________________________
CPU SPEED
_________________________________________________________________________________________________________
Reported CPU speed: 3214.0 MHz
Measured CPU speed: 4259.0 MHz (approx.)

Note: reported execution times may be calculated based on a fixed reported CPU speed. Disable variable speed settings like Intel Speed Step and AMD Cool N Quiet in the BIOS setup for more accurate results.


_________________________________________________________________________________________________________
MEASURED INTERRUPT TO USER PROCESS LATENCIES
_________________________________________________________________________________________________________
The interrupt to process latency reflects the measured interval that a usermode process needed to respond to a hardware request from the moment the interrupt service routine started execution. This includes the scheduling and execution of a DPC routine, the signaling of an event and the waking up of a usermode thread from an idle wait state in response to that event.

Highest measured interrupt to process latency (µs): 796.070552
Average measured interrupt to process latency (µs): 2.531378

Highest measured interrupt to DPC latency (µs): 216.617837
Average measured interrupt to DPC latency (µs): 0.720980


_________________________________________________________________________________________________________
REPORTED ISRs
_________________________________________________________________________________________________________
Interrupt service routines are routines installed by the OS and device drivers that execute in response to a hardware interrupt signal.

Highest ISR routine execution time (µs): 22.862166
Driver with highest ISR routine execution time: ataport.SYS - ATAPI Driver Extension, Microsoft Corporation

Highest reported total ISR routine time (%): 0.032661
Driver with highest ISR total time: USBPORT.SYS - USB 1.1 & 2.0 Port Driver, Microsoft Corporation

Total time spent in ISRs (%) 0.071912

ISR count (execution time <250 µs): 91136
ISR count (execution time 250-500 µs): 0
ISR count (execution time 500-999 µs): 0
ISR count (execution time 1000-1999 µs): 0
ISR count (execution time 2000-3999 µs): 0
ISR count (execution time >=4000 µs): 0


_________________________________________________________________________________________________________
REPORTED DPCs
_________________________________________________________________________________________________________
DPC routines are part of the interrupt servicing dispatch mechanism and disable the possibility for a process to utilize the CPU while it is interrupted until the DPC has finished execution.

Highest DPC routine execution time (µs): 203.894213
Driver with highest DPC routine execution time: ntoskrnl.exe - NT Kernel & System, Microsoft Corporation

Highest reported total DPC routine time (%): 0.981034
Driver with highest DPC total execution time: USBPORT.SYS - USB 1.1 & 2.0 Port Driver, Microsoft Corporation

Total time spent in DPCs (%) 1.141843

DPC count (execution time <250 µs): 470033
DPC count (execution time 250-500 µs): 0
DPC count (execution time 500-999 µs): 0
DPC count (execution time 1000-1999 µs): 0
DPC count (execution time 2000-3999 µs): 0
DPC count (execution time >=4000 µs): 0


_________________________________________________________________________________________________________
REPORTED HARD PAGEFAULTS
_________________________________________________________________________________________________________
Hard pagefaults are events that get triggered by making use of virtual memory that is not resident in RAM but backed by a memory mapped file on disk. The process of resolving the hard pagefault requires reading in the memory from disk while the process is interrupted and blocked from execution.


Process with highest pagefault count: loggingserver.exe

Total number of hard pagefaults 2
Hard pagefault count of hardest hit process: 1
Highest hard pagefault resolution time (µs): 8.043248
Total time spent in hard pagefaults (%): 0.000005
Number of processes hit: 2


_________________________________________________________________________________________________________
PER CPU DATA
_________________________________________________________________________________________________________
CPU 0 Interrupt cycle time (s): 1.031067
CPU 0 ISR highest execution time (µs): 16.367455
CPU 0 ISR total execution time (s): 0.092221
CPU 0 ISR count: 71429
CPU 0 DPC highest execution time (µs): 203.894213
CPU 0 DPC total execution time (s): 0.277583
CPU 0 DPC count: 359105
_________________________________________________________________________________________________________
CPU 1 Interrupt cycle time (s): 0.661380
CPU 1 ISR highest execution time (µs): 10.648413
CPU 1 ISR total execution time (s): 0.000787
CPU 1 ISR count: 122
CPU 1 DPC highest execution time (µs): 127.432794
CPU 1 DPC total execution time (s): 0.025197
CPU 1 DPC count: 1014
_________________________________________________________________________________________________________
CPU 2 Interrupt cycle time (s): 0.444867
CPU 2 ISR highest execution time (µs): 15.430927
CPU 2 ISR total execution time (s): 0.003611
CPU 2 ISR count: 539
CPU 2 DPC highest execution time (µs): 198.360610
CPU 2 DPC total execution time (s): 0.067938
CPU 2 DPC count: 4326
_________________________________________________________________________________________________________
CPU 3 Interrupt cycle time (s): 3.571841
CPU 3 ISR highest execution time (µs): 22.862166
CPU 3 ISR total execution time (s): 0.108320
CPU 3 ISR count: 19046
CPU 3 DPC highest execution time (µs): 168.638146
CPU 3 DPC total execution time (s): 2.883350
CPU 3 DPC count: 105588
_________________________________________________________________________________________________________



I have followed all the optimisation steps from the Focurite answerbase, any it hasn't made any difference.
I also got to try the interface on my Dad's Win 7 system, and it worked flawlessly! His system is horribly maintained, full of bloatware and malware, not optimised in any way and it works perfectly!?

I have a clean installed windows, updated all drivers (inc, Graphics, LAN, chipset, USB etc), I have disabled my on-board sound from the bios. The only thing I haven't tried in uninstalling my Radeon HD5750. I have some USB 3 ports, but I've read that the Scarlett specifically needs a 2.0 slot so haven't tried using USB 3.
Just to note, the Scarlett audio control panel worked correctly on my Dad's machine. But on mine it never remembers the setting I select (Recording-Balanced-Mixing).

Thanks again for you help with this>

Adrian Deans

[ Post last edited on 01/17/2015 at 07:12:35 ]

Adrian Deans

user offline
Adrian Deans
4 posts
New AFfiliate

5 Posted on 01/17/2015 at 15:33:29Direct link to this post
IT'S WORKING!!!!!!!!!!!

I plugged the Scarlett into a USB 3 port (even I read online somewhere not to) and it works!!
I'm so excited I cant believe it, I made up big time. Getting my first AI has been a long time coming, I was so gutted out this not working, I was a real blow, but this is just awesome, I'm so happy. I'm sounding like a tennager and I'm 33 years oldhttps://static.audiofanzine.com/images/audiofanzine/interface/smileys/icon_mrgreen.gif

Simon, thanks for your help with this, I've been impressed with Focusrite's customer service during this whole episode, so I'm glad to own a product from a company that has my respect.
Thanks again https://static.audiofanzine.com/images/audiofanzine/interface/smileys/icon_bravo.gif

Adrian Deans

Simon Focusrite

user offline
Simon Focusrite
207 posts
AFfinity Poster

6 Posted on 01/23/2015 at 02:06:55Direct link to this post
Hi Adrian,

That's great to hear, glad you're up working and enjoying the 18i20.
Yes, it's often less to do with USB2.0 vs USB3.0 (3.0 is largely backwards compatible) but some USB ports can be a bit difficult depending on how they're arranged internally on the motherboard, swapping around USB ports can yield surprisingly positive results for devices not working as they should.

If you need anything else, please do get in contact.
Best regards
Simon // Focusrite Technical Support

[ Post last edited on 01/23/2015 at 02:08:16 ]

Mfrazier43

user offline
Mfrazier43
1 post
New AFfiliate

7 Posted on 04/12/2016 at 18:57:37Direct link to this post
Im having poping sounds from my solo also.let me say i like this interface a lot, my work around is i use my pc headphone output for playback,and just only use the solo for tracking my vocals.sn: this issue makes me cautious about focusrite a little i know several people personally that have this issue

astro33

user offline
astro33
1 post
New AFfiliate

8 Posted on 10/29/2016 at 22:23:28Direct link to this post
I have a same problem on my winndows 7 system

I have a solution

1. unplug usb port from Scarlett Solo
2. uninstall Scarlett Solo driver
3. install Scarlett Solo driver
4. reboot

<important thing>

buy usb hub and use usb hub and plug in Scarlett Solo
(usb hub should be plug in usb 3.0)

I guarantee 100% success
No more Popping noise

https://s14.postimg.org/nuc09ndz5/20161030_142542.jpg

[ Post last edited on 10/29/2016 at 22:29:14 ]

jacksonpollock

user offline
jacksonpollock
1 post
New AFfiliate

9 Posted on 11/10/2017 at 16:46:22Direct link to this post
Hi!
I haven't read everything but wanted to share my solution.
I have scarlett usb solo 2ng gen on windows 10 64 bits with latest drivers into USB 3 directly on computer port.
I had popping noise.

I tried pluging a usb 3.0 hub and plugging the scarlette solo into the hub.
Still popping.

Then I tried another usb 3.0 hub then plugged the scarlett solo.
And no more popping even if I lower the buffer size.

my thinking is that scarlett solo is optimised for usb 2.0 and if plugged into usb 3.0 , the latter needs to do the usb 2.0 fallback correctly.

I might be wrong...
anyway, if yours still doesn't work tried different usb hub...


hope it can help!

antonioctd

user offline
antonioctd
1 post
New AFfiliate

10 Posted on 11/30/2017 at 05:01:07Direct link to this post
Yah... I have a Scarlett 2i4 first gen. Also running in a nice windows 10 i7 Laptop
Popping, glitches, etc...

All the power saving and performing settings are optimized and the drivers are the latest.

I'm thinking it's an issue with power saving. Please tell me: all of you experiencing this are on Laptops? Just to check if it is due to power saving on Laptops USB...

Anyway, if that's the case, perhaps it can be solved with a powered usb hub?
Go back to top