Log in
Log in

or
Create an account

or

Thread Focusrite issues - Liquid 56

  • 1 comment
  • 2 participants
  • 933 views
  • 2 followers
1 Focusrite issues - Liquid 56
Just wondering if people have found it difficult to live with the Liquid 56 in Windows.

I've had the card for several years, starting with W7, now W10, and I get loads of problems with the card, always have.
First off, it was nigh impossible to get recognized by the system. During the years I have used it thru Thunderbolt (never worked right) and about 5 different FW cards. The current one is the recommended Unibrain, but even that only works if I force it to use a 'Texas Instruments OCHI Compliant' firewire card driver. Otherwise the card just doesn't get noticed.

Lately I've gotten it to work rather OK. But, what remains is first off, every time Windows has a bigger update, it gets haywire somehow.

Just the other day there was Windows update - and I could not get any sound in Windows from the card. 'No audio device' etc. even though it shows right in Settings and even volume bar says Saffire and no errors - but no sound. Except in Cubase and other ASIO sound programs it works fine.

After several attempts at rebooting and switching it on and off and reinstalling Saffire mix control it is now back, and even Windows sound works correctly. Only took me 2 hours to sort it out again.

Another ever-constant annoyance is that when I start up the machine and the card, typically for a good while there is sound from the headphones jacks, but no sound from mains outs. And the front panel volume knob doesn't work.

Sometimes it helps to 'load settings from hardware' or shut off the card and back again, but most often nothing helps except waiting 5-10 minutes and BOOM suddenly there is sound also from mains out and the master volume knob works again.

It's very likely though that there is still no sound from SPDIF though (optical) and need to wait a little bit longer still. But eventually it does come up again.

Also, if I leave the system on for 24 hours, the sound might vanish again and need a reboot to get it back.

So how about it, does this all sound like typical Focusrite driver issues or what?

I've contacted their support so many times they probably notice my name already, but, well, it's always the same thing. Swapping drivers around and rebooting generally makes it work OK, more or less, and that's the end of it.

But I'm surely starting to get VERY tired of meddling it with every other time I have to start working...

Anybody have the same issues?
2
Hi Deeaa,

I'm Alex from Focusrite Tech Support and I would like to try and help with your Liquid Saffire 56 problem that you seem to be having, I'm sorry for all the trouble it's causing you.

The first issue where you are losing sound is probably because the driver is being exclusively used by an application and is a setting in Windows which needs changing. The reason this occurs particularly after a Windows update is that these settings tend to revert to the default whenever there is a significant Windows Update. Please follow the steps in the article below which should solve the issue. Please also be aware that this is likely to revert back to the default setting when you have another key Windows Update.

https://support.focusrite.com/hc/en-gb/articles/115005113405-I-m-losing-audio-in-Windows-when-I-switch-applications

Once you've changed this setting, this should fix all of the problems that you have described.

If you're still having issues after this then please get in touch with us via our support form and we can troubleshoot further.

https://support.focusrite.com/hc/en-gb/requests/new

Best regards,

Alex Bull // Focusrite Tech Support