Log in
Log in

or
Create an account

or

Thread Saffire Pro 40 Windows 10 Problem

  • 15 replies
  • 10 participants
  • 21,339 views
  • 10 followers
1 Saffire Pro 40 Windows 10 Problem
Hello guys and girls,

I'm desperate, maybe some of you could help me. I've upgraded to windows 10 recently...
My problem is, everything works fine except the saffire mix control.
The Saffire pro 40 I'm working with, is recognized by Windows, all drivers are working proberbly (thinks Windows), but i cannot get it to work. Everytime I Start Mix Control it cannot find my Interface.

I'm using a PCI-E Firewirecard with the OHCI Conform Via driver. I tried to run compatiblity mode, with windows 7 , 8 and XP settings... nothing, also I ran as Admin... nothing. I even uninstalled and reinstalled the mix control software (3.6, 3.5 and 3.2 I tried them all) with and without the Pro 40 plugged in.

I dunno what to do, please can somebody help my? As far as focusrite is concerned they claim, the pro 40 is compatible with Windows 10 but it doesent seem so

[ Post last edited on 08/09/2015 at 01:53:37 ]

2
Hi Alexander,

Please can you let me know what motherboard make and model you have, as well as which make and model of Firewire card?
Once I know this information I can advise further.
Presumably the exact same setup was working on your previous Win 7/8 setup?
So you can setup yourself up, it will be Mix Control 3.6 that you will want installed for Windows 10

Many thanks
Simon // Focusrite Technical Support
3
Hello everyone.

I have upgraded to windows 10 recently too.
I'm working with 2 saffire pro 40 in dual unit on a Dell E6530 laptop with a pcmcia Firewire card (ExpressCard with a Texas Instrument chipset).
The mix control used is 3.6.
In windows 7 everythings works perfectly.

The problem is that, with windows 10, the second unit does not stably locked with the first one.
The firewire driver used is OHCI Texas instruments compatible ...
The setup is the same as Windows 7.
The consequence is that cuts in inputs and outputs and some crackling coming from the second module inputs.

So, I came back to the windows 7 and everythings works perfectly.

Pity. I love the Saffire Pro 40 I use for home studio and even a few live recordings.
This is a problem with the driver? the Mix control ? ... I don't know...
4
HI,

I've changed my Firewire Card, it had a VIA chipset and wasn't working correctly... though I don't know why this problem occurs on Windows 10 ... Mainboard is a ASUS ROG HERO VII. Firewire Card was a noname logilink or sth. I think.
5
If it's of any help, I managed to get my Saffire Pro 40 working on Windows 10 by downloading the legacy FireWire driver from https://support.microsoft.com/en-us/kb/2970191. Although it says Windows 8, it works for Windows 10 as well. It required a reboot both the PC and the Saffire Pro 40 to make it work.

[ Post last edited on 08/16/2015 at 05:35:00 ]

6
Hi guys,

We have heard some reports that some Firewire cards that utilise the VIA chipsets, seemingly when combined with certain motherboards, appear to have difficulty with Windows 10. We're exporting this currently, however there are a lot of variables here.
With some customers who were experiencing these issues, changing from a VIA chipset to a TI chipset card seemed to resolve their issues, and so we don't believe that the issue is with our drivers/Mix Control & Windows 10. Similarly these customers also had no issues on previous versions of Windows.
We are continuing to explore where the issue could lie, even if it is to give further advice on hardware.

Similarly, with Dual Mode, we're not aware of any particular issues on Windows 10, however this will form part of our Firewire card testing.

Hope this helps
Please do let me know if you need anything else.

Simon // Focusrite Technical Support
7
Hi guys. I have the same problem.
A little trick that worked for me. Try it out.
When i turn on pc my Saffire Pro 24 FW Indicator does't turn on and i have no sound.
I just RESTART my pc and it works fine.
I don't know why.

Just try it.
8
Has there been any progress in solving the VIA/Win10 problem? Every day without my Saffire is a very sad day... :(((
9
Hi, I would also like to hear of any progress. I have the exact same issue on windows 8.1 Professional with pro 40 and the recommended siig 2-port FireWire card.

Pro 40 appears in native windows devices as speakers and midi in/out, however mixcontrol freezes for a few seconds when opened, then acts as if the device is not connected.

This is a clean windows install, on a new system using the latest Intel skylake Z170 chipset with DDR4 ram and PCI 3 slots. I have tried the alternative built in drivers and older mixcontrol versions with no luck.

Please let me know of any progress, cheers.

James

[ Post last edited on 09/17/2015 at 16:50:00 ]

10
Hi Bushfluff,

We're not aware of any issues between any particular Firewire card chipsets and Windows 8, as such, your issue is likely to be different to those who have installed Windows 10.
I would recommend starting an email case with us here:

https://global.focusrite.com/answerbase/contact

With regards to those having issues with Windows 10, we are still trying to nail down where the issue lies. A few different customers have posted various workarounds, changing to TI chipsets, changing the generation of the PCIe slot (if using a PCIe Firewire card) in the BIOS from 'Auto' to 'One'.
There has also been a suggestion from some users that migrating the Firewire driver from Windows 7, to Windows 10, has solved the issue, which we are exploring. If this is true, then it suggests an issue between Via & Windows 10, which we obviously have little impact upon, however we continue to look at all areas incase we can improve or effect a solution.

Hope this helps.
Simon // Focusrite Technical Support

[ Post last edited on 09/18/2015 at 02:59:50 ]