Log in
Log in

Create an account


Thread Focusrite Scarlett 2i2 keeps disconnecting and reconnecting

  • 6 replies
  • 3 participants
1 Focusrite Scarlett 2i2 keeps disconnecting and reconnecting
I have bought the Scarlett 2i2 today, and I was looking forward to trying it.
I followed every step on the website in order to install drivers, but when I plugged my Scarlett 2i2 in, it kept disconnecting and reconnecting every time.
I tried to install other drivers, put when I press the button, the same problem occures.
Please help :(
Hi Daniel,

You mention that when you press the button, the 2i2 disconnects and then reconnects? Please can you let me know which button you're pressing that causes the issue.
Please can you also let me know what version of operating system you have installed (Windows PC or Mac OSX?), this will determine what troubleshooting we continue with.

Best regards
Simon // Focusrite Technical Support
I use Windows 7,and this problem occures when I press the ONLY button on Scarlett 2i2.
Solved,thanks for the "help".:bravo:
Would you be so kind to share your solution so others with the same problems can try it too?

- Angelie

It's not about what you got to use ....    but how you use what you got...

Sure,I just used a self powered usb hub, because my USB ports on my laptop didn't give enough power to the Scarlett 2i2.
I hope this helps, cya.
Hi Daniel,

Glad you are now up and running. As you mention, the problem may be as a result of the 2i2 not receiving what it needs from the USB port. You may wish to take a look at the following optimisation steps to see if it leads to you not needing the usb hub:

Optimisation steps:

Please ensure you have disabled power saving mode for USB devices:

In the device manager (Start > Control Panel > System and Security > System > Device Manager), in the Universal Serial Bus controllers section, right click each USB Root Hub, choose Properties > Power Management and untick the Allow the computer to turn off this device to save power option.

USB Power

If using a Laptop, it could also be worth checking the general power management of your computer:
Go to Start > Control Panel > System and Security > Power Options.
Set the Power Scheme to High Performance (if this setting is not available, click on Show additional plans first). Then click on Change plan settings. On the next page set both Turn off the display and Put the computer to sleep to Never.

Power Options

Then click Change advanced power settings. In the window that opens make sure you have the following settings:
Hard disc > Turn off hard disk after > Setting (Minutes) = Never
Sleep > Sleep after > Setting (Minutes) = Never
USB settings > USB selective suspend setting > Setting = Disabled
Display > Turn off display after > Setting (Minutes) = Never
Processor power management > Minimum processor state > Setting = 100%
Processor power management > Maximum processor state > Setting = 100%

Please note, not all options may be available.
Have you tried another USB port? Some are internally hubbed and can cause issues. Please try each one and monitor the performance of the interface.

It could also be worth checking for any available USB/Chipset driver updates for your motherboard, including the latest BIOS updates.

Hopefully this may help some more.
Best regards
Simon // Focusrite Technical Support